aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 000000000..2f9a6edf2
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,21 @@
+project(pyside2_super_project)
+
+cmake_minimum_required(VERSION 3.1)
+cmake_policy(VERSION 3.1)
+
+if (CMAKE_SOURCE_DIR STREQUAL CMAKE_BINARY_DIR)
+ message(FATAL_ERROR "In-source builds are not allowed.")
+endif()
+
+# Used to prevent overriding message function in both shiboken2 and pyside2.
+set(is_pyside2_superproject_build 1)
+
+add_subdirectory(sources/shiboken2)
+
+# Semi-hack to include exported shiboken variables.
+list(APPEND CMAKE_PREFIX_PATH "${CMAKE_CURRENT_BINARY_DIR}/sources/shiboken2/data")
+add_subdirectory(sources/pyside2)
+
+# Semi-hack to include exported pyside2 variables.
+list(APPEND CMAKE_PREFIX_PATH "${CMAKE_CURRENT_BINARY_DIR}/sources/pyside2/libpyside")
+add_subdirectory(sources/pyside2-tools)