aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 47ab784fa..5c50500ad 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -179,6 +179,12 @@ enable_testing()
add_subdirectory(libpyside)
# project directories
-add_subdirectory(${BINDING_NAME})
+add_subdirectory(PySide)
add_subdirectory(tests)
-add_subdirectory(doc)
+
+find_program(DOT_EXEC dot)
+if (QT_SRC_DIR AND DOT_EXEC)
+ add_subdirectory(doc)
+else ()
+ message(STATUS "QT_SRC_DIR variable not set or graphviz not found, apidoc generation targets disabled.")
+endif()