aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5ba7022bd..47ab784fa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -169,7 +169,9 @@ if(CMAKE_BUILD_TYPE STREQUAL "Debug")
else()
set(PYSIDE_PYTHON_LIBRARIES ${PYTHON_LIBRARIES})
endif()
-
+if(APPLE)
+ set(PYSIDE_PYTHON_LIBRARIES "-undefined dynamic_lookup")
+endif()
set(GENERATOR_EXTRA_FLAGS --generatorSet=shiboken --enable-parent-ctor-heuristic --enable-pyside-extensions --enable-return-value-heuristic)