aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 98a007de3..d698696b5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -92,8 +92,9 @@ if(CMAKE_BUILD_TYPE STREQUAL "Debug")
endif()
if(NOT PY_DEBUG)
message(WARNING "Compiling shiboken with debug enabled, but the python executable was not compiled with debug support.")
+ else()
+ add_definitions("-DPy_DEBUG")
endif()
- add_definitions("-DPy_DEBUG")
set(SBK_PYTHON_LIBRARIES ${PYTHON_DEBUG_LIBRARIES})
else()
set(SBK_PYTHON_LIBRARIES ${PYTHON_LIBRARIES})