aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt20
1 files changed, 15 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c2cdbd611..e6d3034d2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,16 +7,20 @@ find_package(Qt4 4.5.0 REQUIRED)
find_package(LibXml2 2.6.32 REQUIRED)
find_package(LibXslt 1.1.19 REQUIRED)
+option(BUILD_TESTS "Build tests." TRUE)
+
if (MSVC)
set(CMAKE_CXX_FLAGS "/DWIN32 /D_WINDOWS /w /EHsc- /GS- /GR- /DAPIEXTRACTOR_ENABLE_DUPLICATE_ENUM_VALUES /DAPIEXTRACTOR_BUILD -D_SCL_SECURE_NO_WARNINGS")
else (MSVC)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -DAPIEXTRACTOR_ENABLE_DUPLICATE_ENUM_VALUES -fvisibility=hidden")
endif(MSVC)
-set(LIBRARY_OUTPUT_PATH ${CMAKE_BINARY_DIR}/tests)
+if (BUILD_TESTS)
+ set(LIBRARY_OUTPUT_PATH ${CMAKE_BINARY_DIR}/tests)
+endif()
set(apiextractor_MAJOR_VERSION 0)
-set(apiextractor_MINOR_VERSION 4)
-set(apiextractor_MICRO_VERSION 1)
+set(apiextractor_MINOR_VERSION 5)
+set(apiextractor_MICRO_VERSION 0)
set(apiextractor_VERSION "${apiextractor_MAJOR_VERSION}.${apiextractor_MINOR_VERSION}.${apiextractor_MICRO_VERSION}")
configure_file(apiextractorversion.h.in ${CMAKE_CURRENT_BINARY_DIR}/apiextractorversion.h @ONLY)
set(QT_USE_QTCORE 1)
@@ -40,6 +44,8 @@ graph.cpp
reporthandler.cpp
typeparser.cpp
typesystem.cpp
+include.cpp
+typedatabase.cpp
parser/ast.cpp
parser/binder.cpp
parser/class_compiler.cpp
@@ -110,10 +116,14 @@ typesystem.h
fileout.h
docparser.h
qtdocparser.h
+include.h
+typedatabase.h
)
-enable_testing()
-add_subdirectory(tests)
+if (BUILD_TESTS)
+ enable_testing()
+ add_subdirectory(tests)
+endif()
install(FILES ${root_HEADERS} DESTINATION include/apiextractor)
install(TARGETS apiextractor EXPORT apiextractor