aboutsummaryrefslogtreecommitdiffstats
path: root/PySide/QtDeclarative/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'PySide/QtDeclarative/CMakeLists.txt')
-rw-r--r--PySide/QtDeclarative/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/PySide/QtDeclarative/CMakeLists.txt b/PySide/QtDeclarative/CMakeLists.txt
index 98673f7a3..0fc96d40a 100644
--- a/PySide/QtDeclarative/CMakeLists.txt
+++ b/PySide/QtDeclarative/CMakeLists.txt
@@ -1,7 +1,6 @@
project(QtDeclarative)
set(QtDeclarative_SRC
-${CMAKE_CURRENT_SOURCE_DIR}/pysideqmlregistertype.cpp
${CMAKE_CURRENT_BINARY_DIR}/PySide/QtDeclarative/qdeclarativecomponent_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/PySide/QtDeclarative/qdeclarativecontext_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/PySide/QtDeclarative/qdeclarativeengine_wrapper.cpp
@@ -50,12 +49,13 @@ set(QtDeclarative_libraries pyside
${QT_QTDECLARATIVE_LIBRARY})
set(QtDeclarative_deps QtGui QtNetwork)
-
+set(QtDeclarative_registerType "${CMAKE_CURRENT_SOURCE_DIR}/pysideqmlregistertype.cpp")
create_pyside_module(QtDeclarative
QtDeclarative_include_dirs
QtDeclarative_libraries
QtDeclarative_deps
QtDeclarative_typesystem_path
QtDeclarative_SRC
- "")
+ ""
+ QtDeclarative_registerType)