aboutsummaryrefslogtreecommitdiffstats
path: root/PySide/QtGui/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'PySide/QtGui/CMakeLists.txt')
-rw-r--r--PySide/QtGui/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/PySide/QtGui/CMakeLists.txt b/PySide/QtGui/CMakeLists.txt
index f4ec6d324..b2a5545d2 100644
--- a/PySide/QtGui/CMakeLists.txt
+++ b/PySide/QtGui/CMakeLists.txt
@@ -373,6 +373,10 @@ ${SPECIFIC_OS_FILES}
${QtGui_46_SRC}
)
+
+configure_file("${CMAKE_CURRENT_SOURCE_DIR}/typesystem_gui.xml.in"
+ "${CMAKE_CURRENT_BINARY_DIR}/typesystem_gui.xml" @ONLY)
+
check_qt_class(QtGui QGtkStyle QtGui_SRC)
check_qt_class(QtGui QSessionManager QtGui_SRC)
check_qt_class(QtGui QSizeGrip QtGui_SRC)
@@ -407,5 +411,6 @@ create_pyside_module(QtGui
QtGui_libraries
QtGui_deps
QtGui_typesystem_path
- QtGui_SRC)
+ QtGui_SRC
+ "${CMAKE_CURRENT_BINARY_DIR}/typesystem_gui.xml")