aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rw-r--r--debian/compat1
-rw-r--r--debian/control25
-rw-r--r--debian/copyright37
-rwxr-xr-xdebian/rules15
5 files changed, 84 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 000000000..b8f9d4895
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,6 @@
+shiboken (0.2) unstable; urgency=low
+
+ * Initial release
+
+ -- Marcelo Lira <marcelo.lira@indt.org.br> Sat, 30 May 2009 16:16:00 -0300
+
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 000000000..7ed6ff82d
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+5
diff --git a/debian/control b/debian/control
new file mode 100644
index 000000000..e7fb555a8
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,25 @@
+Source: shiboken
+Section: devel
+Priority: extra
+Maintainer: Marcelo Lira <marcelo.lira@indt.org.br>
+Build-Depends: cdbs, debhelper (>= 5), libapiextractor-dev (>= 0.2), libqt4-dev (>= 4.5), cmake (>= 2.6.0)
+Standards-Version: 3.7.3
+
+Package: shiboken
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}, libapiextractor (>= 0.2)
+Description: Generates Python bindings for qt based libraries.
+ Generates CPython based bindings for C++ libraries.
+
+Package: libshiboken
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: Support library for Python bindings created with Shiboken generator.
+ Support library for Python bindings created with Shiboken generator.
+
+Package: libshiboken-dev
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}, libshiboken
+Description: Development files for libshiboken.
+ Development files for libshiboken.
+
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 000000000..bef1d32de
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,37 @@
+This package was debianized based on previous debianization by Marcelo Lira <marcelo.lira@indt.org.br> on
+Sat, 30 May 2009 16:16:00 -0300.
+
+Upstream Authors:
+
+ Hugo Lima <hugo.lima@indt.org.br>
+ Luciano Wolf <luciano.wolf@indt.org.br>
+ Marcelo Lira <marcelo.lira@indt.org.br>
+ Renato Araujo <renato.filho@indt.org.br>
+
+Copyright:
+
+ Copyright (C) 2009 Nokia Corporation and/or its subsidiary(ies)
+
+License:
+
+ This package is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This package is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this package; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+
+ On Debian systems, the complete text of the GNU General Public License
+ can be found in `/usr/share/common-licenses/GPL'.
+
+
+The Debian packaging is (C) 2009, Nokia Corporation and
+is licensed under the GPL, see `/usr/share/common-licenses/GPL'.
+
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 000000000..1e6acdd00
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,15 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+
+
+# Add here any variable or target overrides you need.
+
+DEB_CMAKE_EXTRA_FLAGS=-DCMAKE_MODULE_PATH=/usr/share/cmake-2.6/Modules
+
+# borrowed from python2.5 debian/rules
+COMMA = ,
+ifneq (,$(filter parallel=%,$(subst $(COMMA), ,$(DEB_BUILD_OPTIONS))))
+ DEB_MAKE_ENVVARS := MAKEFLAGS=-j$(subst parallel=,,$(filter parallel=%,$(subst $(COMMA), ,$(DEB_BUILD_OPTIONS))))
+endif