aboutsummaryrefslogtreecommitdiffstats
path: root/libpyside/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libpyside/CMakeLists.txt')
-rw-r--r--libpyside/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/libpyside/CMakeLists.txt b/libpyside/CMakeLists.txt
index 806160e3e..94c8abccd 100644
--- a/libpyside/CMakeLists.txt
+++ b/libpyside/CMakeLists.txt
@@ -32,6 +32,11 @@ set(libpyside_HEADERS
signalmanager.h
)
+# create pkg-config file
+configure_file("${CMAKE_CURRENT_SOURCE_DIR}/pyside.pc.in"
+ "${CMAKE_CURRENT_BINARY_DIR}/pyside.pc" @ONLY)
+
install(FILES ${libpyside_HEADERS}
DESTINATION include/${BINDING_NAME})
install(TARGETS pyside LIBRARY DESTINATION ${LIB_INSTALL_DIR})
+install(FILES "${CMAKE_CURRENT_BINARY_DIR}/pyside.pc" DESTINATION "${LIB_INSTALL_DIR}/pkgconfig")