aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py24
1 files changed, 18 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index ca26084d6..9ab77af46 100644
--- a/setup.py
+++ b/setup.py
@@ -60,6 +60,8 @@ For Windows, if OpenSSL support is required, it's necessary to specify
the directory path that contains the OpenSSL shared libraries
"libeay32.dll" and "ssleay32.dll", for example:
--openssl=C:\OpenSSL-Win64\bin
+This will make sure that the libraries are copied into the PySide2
+package and are found by the QtNetwork module.
ADDITIONAL OPTIONS:
@@ -138,6 +140,10 @@ using `setup.py build`:
--skip-docs skip the documentation generation.
--limited-api=yes|no default yes if applicable
Set or clear the limited API flag. Ignored for Python 2.
+ --package-timestamp allows specifying the timestamp that will be
+ used as part of the version number for a snapshot package.
+ For example given --package-timestamp=1529646276
+ the package version will be 5.x.y.dev1529646276.
REQUIREMENTS:
@@ -150,9 +156,14 @@ REQUIREMENTS:
OPTIONAL:
* OpenSSL:
- Specifying the --openssl option is only required on Windows.
+ Specifying the --openssl option only affects Windows.
It is a no-op for other platforms.
+ Please note that official Windows packages do not ship the
+ OpenSSL libraries due to import / export restrictions as
+ described in
+ http://doc.qt.io/qt-5/ssl.html#import-and-export-restrictions
+
You can specify the location of the OpenSSL DLLs with the
following option:
--openssl=</path/to/openssl/bin-directory>.
@@ -177,7 +188,7 @@ OPTIONAL:
shared libraries, are not currently compatible with
standalone PySide2 packages.
- (*) Revised on 23.03.2018
+ (*) Revised on 21.06.2018
* macOS SDK:
You can specify which macOS SDK should be used for compilation with
@@ -259,6 +270,7 @@ setup(
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
'Topic :: Database',
'Topic :: Software Development',
'Topic :: Software Development :: Code Generators',
@@ -267,10 +279,10 @@ setup(
'Topic :: Software Development :: Widget Sets',
],
keywords = 'Qt',
- author = 'PySide2 Team',
- author_email = 'contact@pyside.org',
- url = 'http://www.pyside.org',
- download_url = 'https://download.qt-project.org/official_releases/pyside2/',
+ author = 'Qt for Python Team',
+ author_email = 'pyside@qt-project.org',
+ url = 'https://www.pyside.org',
+ download_url = 'https://download.qt.io/official_releases/QtForPython/',
license = 'LGPL',
packages = ['PySide2', 'pyside2uic',
'pyside2uic.Compiler',