aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 0be9d1a33..79a82cfe2 100644
--- a/setup.py
+++ b/setup.py
@@ -282,7 +282,7 @@ if OPTION_NOEXAMPLES:
# Return a prefix suitable for the _install/_build directory
def prefix():
- virtualEnvName = os.environ['VIRTUAL_ENV']
+ virtualEnvName = os.environ.get('VIRTUAL_ENV', None)
name = os.path.basename(virtualEnvName) if virtualEnvName is not None else 'pyside'
name += str(sys.version_info[0])
if OPTION_DEBUG: