aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index e7553aacb..462913532 100644
--- a/setup.py
+++ b/setup.py
@@ -905,8 +905,8 @@ class pyside_build(_build):
clangBinDir, clangDir[1]))
additionalPaths.append(clangBinDir)
else:
- log.error("Failed to detect Clang by checking "
- "LLVM_INSTALL_DIR, CLANG_INSTALL_DIR, llvm-config")
+ raise DistutilsSetupError("Failed to detect Clang when checking "
+ "LLVM_INSTALL_DIR, CLANG_INSTALL_DIR, llvm-config")
update_env_path(additionalPaths)