aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 6 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index ad6303569..ca26084d6 100644
--- a/setup.py
+++ b/setup.py
@@ -136,6 +136,8 @@ using `setup.py build`:
--sanitize-address will build the project with address sanitizer
enabled (Linux or macOS only).
--skip-docs skip the documentation generation.
+ --limited-api=yes|no default yes if applicable
+ Set or clear the limited API flag. Ignored for Python 2.
REQUIREMENTS:
@@ -217,7 +219,7 @@ this_file = os.path.abspath(this_file)
if os.path.dirname(this_file):
os.chdir(os.path.dirname(this_file))
-from build_scripts.main import get_package_version
+from build_scripts.main import get_package_version, get_setuptools_extension_modules
from build_scripts.main import pyside_package_dir_name
from build_scripts.main import cmd_class_dict
from build_scripts.main import README, CHANGES
@@ -227,6 +229,8 @@ from setuptools import setup, Extension
# used as a value source.
__version__ = get_package_version()
+extension_modules = get_setuptools_extension_modules()
+
setup(
name = "PySide2",
version = get_package_version(),
@@ -249,7 +253,6 @@ setup(
'Programming Language :: C++',
'Programming Language :: Python',
'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.3',
@@ -285,6 +288,6 @@ setup(
# are overriding the build command to do it using cmake) so things
# like bdist_egg will know that there are extension modules and
# will name the dist with the full platform info.
- ext_modules = [Extension('QtCore', [])],
+ ext_modules = extension_modules,
ext_package = 'PySide2',
)