aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 6 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 94fecfb4e..559e9286f 100644
--- a/setup.py
+++ b/setup.py
@@ -411,7 +411,12 @@ def get_qt_version():
qt_version = qtinfo.version
if not qt_version:
- log.error("Failed to query the Qt version with qmake %s" % self.qtinfo.qmake_command)
+ log.error("Failed to query the Qt version with qmake {0}".format(self.qtinfo.qmake_command))
+ sys.exit(1)
+
+ if LooseVersion(qtinfo.version) < LooseVersion("5.7"):
+ m = "Incompatible Qt version detected: {0}. A Qt version >= 5.7 is required."
+ log.error(m.format(qt_version))
sys.exit(1)
return qt_version