aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside2/PySide2/QtCore/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sources/pyside2/PySide2/QtCore/CMakeLists.txt')
-rw-r--r--sources/pyside2/PySide2/QtCore/CMakeLists.txt16
1 files changed, 15 insertions, 1 deletions
diff --git a/sources/pyside2/PySide2/QtCore/CMakeLists.txt b/sources/pyside2/PySide2/QtCore/CMakeLists.txt
index e583bd0f4..745d50083 100644
--- a/sources/pyside2/PySide2/QtCore/CMakeLists.txt
+++ b/sources/pyside2/PySide2/QtCore/CMakeLists.txt
@@ -180,6 +180,17 @@ ${SPECIFIC_OS_FILES}
${QtCore_GEN_DIR}/qtcore_module_wrapper.cpp
)
+set(QtCore_glue_sources
+ "${QtCore_SOURCE_DIR}/glue/qbytearray_bufferprotocol.cpp"
+ "${QtCore_SOURCE_DIR}/glue/qbytearray_mgetitem.cpp"
+ "${QtCore_SOURCE_DIR}/glue/qbytearray_msetitem.cpp"
+ "${QtCore_SOURCE_DIR}/glue/qcoreapplication_init.cpp"
+ "${QtCore_SOURCE_DIR}/glue/qeasingcurve_glue.cpp"
+ "${QtCore_SOURCE_DIR}/glue/qeasingcurve_glue.h"
+ "${QtCore_SOURCE_DIR}/glue/qobject_connect.cpp"
+ "${QtCore_SOURCE_DIR}/glue/qobject_findchild.cpp"
+)
+
configure_file("${QtCore_SOURCE_DIR}/typesystem_core.xml.in"
"${QtCore_BINARY_DIR}/typesystem_core.xml" @ONLY)
@@ -202,5 +213,8 @@ create_pyside_module(QtCore
QtCore_SOURCE_DIR
QtCore_SRC
QtCore_gluecode
- ${QtCore_BINARY_DIR}/typesystem_core.xml)
+ ${QtCore_BINARY_DIR}/typesystem_core.xml
+ ""
+ QtCore_glue_sources
+ )