aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside2/PySide2/QtGui/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sources/pyside2/PySide2/QtGui/CMakeLists.txt')
-rw-r--r--sources/pyside2/PySide2/QtGui/CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/sources/pyside2/PySide2/QtGui/CMakeLists.txt b/sources/pyside2/PySide2/QtGui/CMakeLists.txt
index b330a63bf..1e5366733 100644
--- a/sources/pyside2/PySide2/QtGui/CMakeLists.txt
+++ b/sources/pyside2/PySide2/QtGui/CMakeLists.txt
@@ -222,6 +222,10 @@ else()
message(STATUS "Qt5Gui: Adding Desktop OpenGL classes")
endif()
+set(QtGui_glue_sources
+ "${QtGui_SOURCE_DIR}/glue/qguiapplication_init.cpp"
+)
+
configure_file("${QtGui_SOURCE_DIR}/typesystem_gui.xml.in"
"${QtGui_BINARY_DIR}/typesystem_gui.xml" @ONLY)
@@ -252,9 +256,8 @@ create_pyside_module(QtGui
QtGui_SRC
QPYTEXTOBJECT_MOC
${QtGui_BINARY_DIR}/typesystem_gui.xml
- ""
- ""
- QtGui_DROPPED_ENTRIES)
+ QtGui_DROPPED_ENTRIES
+ QtGui_glue_sources)
install(FILES ${pyside2_SOURCE_DIR}/qpytextobject.h DESTINATION include/PySide2/QtGui/)