aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside2/PySide2/QtScript/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sources/pyside2/PySide2/QtScript/CMakeLists.txt')
-rw-r--r--sources/pyside2/PySide2/QtScript/CMakeLists.txt18
1 files changed, 11 insertions, 7 deletions
diff --git a/sources/pyside2/PySide2/QtScript/CMakeLists.txt b/sources/pyside2/PySide2/QtScript/CMakeLists.txt
index 1e06c4644..dfcb80789 100644
--- a/sources/pyside2/PySide2/QtScript/CMakeLists.txt
+++ b/sources/pyside2/PySide2/QtScript/CMakeLists.txt
@@ -18,6 +18,10 @@ ${QtScript_GEN_DIR}/qscriptvalueiterator_wrapper.cpp
${QtScript_GEN_DIR}/qtscript_module_wrapper.cpp
)
+set(QtScript_glue_sources
+ "${QtScript_SOURCE_DIR}/qscript_value_iterator_glue.cpp"
+)
+
set(QtScript_include_dirs ${QtScript_SOURCE_DIR}
${QtScript_BINARY_DIR}
${Qt5Core_INCLUDE_DIRS}
@@ -33,10 +37,10 @@ set(QtScript_libraries pyside2
${Qt5Core_LIBRARIES}
${Qt5Script_LIBRARIES})
set(QtScript_deps QtCore)
-create_pyside_module(QtScript
- QtScript_include_dirs
- QtScript_libraries
- QtScript_deps
- QtScript_SOURCE_DIR
- QtScript_SRC
- "")
+create_pyside_module(NAME QtScript
+ INCLUDE_DIRS QtScript_include_dirs
+ LIBRARIES QtScript_libraries
+ DEPS QtScript_deps
+ TYPESYSTEM_PATH QtScript_SOURCE_DIR
+ SOURCES QtScript_SRC
+ GLUE_SOURCES QtScript_glue_sources)