aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside2/PySide2/QtWebEngineCore/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sources/pyside2/PySide2/QtWebEngineCore/CMakeLists.txt')
-rw-r--r--sources/pyside2/PySide2/QtWebEngineCore/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/sources/pyside2/PySide2/QtWebEngineCore/CMakeLists.txt b/sources/pyside2/PySide2/QtWebEngineCore/CMakeLists.txt
index fe660aa7b..93ff6f5cc 100644
--- a/sources/pyside2/PySide2/QtWebEngineCore/CMakeLists.txt
+++ b/sources/pyside2/PySide2/QtWebEngineCore/CMakeLists.txt
@@ -11,6 +11,11 @@ ${QtWebEngineCore_GEN_DIR}/qwebengineurlschemehandler_wrapper.cpp
${QtWebEngineCore_GEN_DIR}/qtwebenginecore_module_wrapper.cpp
)
+if (Qt5WebEngineCore_VERSION VERSION_EQUAL 5.12.0 OR Qt5WebEngineCore_VERSION VERSION_GREATER 5.12.0)
+ list(APPEND QtWebEngineCore_SRC
+ ${QtWebEngineCore_GEN_DIR}/qwebengineurlscheme_wrapper.cpp)
+endif()
+
set(QtWebEngineCore_include_dirs
${QtWebEngineCore_SOURCE_DIR}
${QtWebEngineCore_BINARY_DIR}