aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside2/PySide2/QtWinExtras/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sources/pyside2/PySide2/QtWinExtras/CMakeLists.txt')
-rw-r--r--sources/pyside2/PySide2/QtWinExtras/CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/sources/pyside2/PySide2/QtWinExtras/CMakeLists.txt b/sources/pyside2/PySide2/QtWinExtras/CMakeLists.txt
index 3593394c3..6c877dfe4 100644
--- a/sources/pyside2/PySide2/QtWinExtras/CMakeLists.txt
+++ b/sources/pyside2/PySide2/QtWinExtras/CMakeLists.txt
@@ -18,21 +18,27 @@ ${QtWinExtras_GEN_DIR}/qwinthumbnailtoolbutton_wrapper.cpp
${QtWinExtras_GEN_DIR}/qtwinextras_module_wrapper.cpp
)
+configure_file("${QtWinExtras_SOURCE_DIR}/QtWinExtras_global.pre.h.in"
+ "${QtWinExtras_BINARY_DIR}/QtWinExtras_global.pre.h" @ONLY)
+
set(QtWinExtras_include_dirs ${QtWinExtras_SOURCE_DIR}
${QtWinExtras_BINARY_DIR}
${Qt${QT_MAJOR_VERSION}WinExtras_INCLUDE_DIRS}
${Qt${QT_MAJOR_VERSION}Core_INCLUDE_DIRS}
${Qt${QT_MAJOR_VERSION}Gui_INCLUDE_DIRS}
+ ${Qt${QT_MAJOR_VERSION}Widgets_INCLUDE_DIRS}
${QtCore_GEN_DIR}
${QtGui_GEN_DIR}
+ ${QtWidgets_GEN_DIR}
${libpyside_SOURCE_DIR})
set(QtWinExtras_libraries pyside2
${Qt${QT_MAJOR_VERSION}WinExtras_LIBRARIES}
${Qt${QT_MAJOR_VERSION}Core_LIBRARIES}
- ${Qt${QT_MAJOR_VERSION}Gui_LIBRARIES})
+ ${Qt${QT_MAJOR_VERSION}Gui_LIBRARIES}
+ ${Qt${QT_MAJOR_VERSION}Widgets_LIBRARIES})
-set(QtWinExtras_deps QtCore QtGui)
+set(QtWinExtras_deps QtCore QtGui QtWidgets)
create_pyside_module(NAME QtWinExtras
INCLUDE_DIRS QtWinExtras_include_dirs