aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside6/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sources/pyside6/CMakeLists.txt')
-rw-r--r--sources/pyside6/CMakeLists.txt15
1 files changed, 1 insertions, 14 deletions
diff --git a/sources/pyside6/CMakeLists.txt b/sources/pyside6/CMakeLists.txt
index 233880997..c24de1b76 100644
--- a/sources/pyside6/CMakeLists.txt
+++ b/sources/pyside6/CMakeLists.txt
@@ -20,17 +20,4 @@ if(BUILD_TESTS)
add_subdirectory(tests)
endif()
-if(QT_SRC_DIR AND SPHINX_BUILD AND DOT_EXEC AND NOT SKIP_DOCS)
- add_subdirectory(doc)
-else()
- set(DOCS_TARGET_DISABLED_MESSAGE "apidoc generation targets disabled.")
- if(NOT QT_SRC_DIR)
- message(STATUS "QT_SRC_DIR variable not set, ${DOCS_TARGET_DISABLED_MESSAGE}")
- elseif(NOT SPHINX_BUILD)
- message(STATUS "sphinx-build command not found, ${DOCS_TARGET_DISABLED_MESSAGE}")
- elseif(NOT DOT_EXEC)
- message(STATUS "graphviz not found, ${DOCS_TARGET_DISABLED_MESSAGE}")
- else()
- message(STATUS "Unknown issue occurred, ${DOCS_TARGET_DISABLED_MESSAGE}")
- endif()
-endif()
+add_subdirectory(doc)