aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside6/doc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sources/pyside6/doc/CMakeLists.txt')
-rw-r--r--sources/pyside6/doc/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/sources/pyside6/doc/CMakeLists.txt b/sources/pyside6/doc/CMakeLists.txt
index af750bcd0..e822992b1 100644
--- a/sources/pyside6/doc/CMakeLists.txt
+++ b/sources/pyside6/doc/CMakeLists.txt
@@ -38,7 +38,11 @@ if (FULLDOCSBUILD)
# so we use the general SRC directory to copy all the other snippets
execute_process(COMMAND ${PYTHON_EXECUTABLE} ${SNIPPETS_TOOL}
--qt ${QT_SRC_DIR}/.. --pyside ${PYSIDE_ROOT} -w ${SNIPPETS_QUIET_OPTION}
- WORKING_DIRECTORY ${CMAKE_CURRENT_LIST_DIR})
+ WORKING_DIRECTORY ${CMAKE_CURRENT_LIST_DIR}
+ ERROR_VARIABLE SNIPPETS_ERROR)
+ if (SNIPPETS_ERROR)
+ message(FATAL_ERROR "The 'snippets_translate' tool failed: ${SNIPPETS_ERROR}")
+ endif()
endif()
# Generate example gallery