aboutsummaryrefslogtreecommitdiffstats
path: root/sources/shiboken2/generator/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sources/shiboken2/generator/CMakeLists.txt')
-rw-r--r--sources/shiboken2/generator/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/sources/shiboken2/generator/CMakeLists.txt b/sources/shiboken2/generator/CMakeLists.txt
index 15b965d9d..1a3f4e5c4 100644
--- a/sources/shiboken2/generator/CMakeLists.txt
+++ b/sources/shiboken2/generator/CMakeLists.txt
@@ -20,7 +20,7 @@ target_include_directories(shiboken2 PRIVATE
${CMAKE_CURRENT_BINARY_DIR}
${apiextractor_SOURCE_DIR}
)
-target_link_libraries(shiboken2 apiextractor Qt5::Core)
+target_link_libraries(shiboken2 apiextractor Qt${QT_MAJOR_VERSION}::Core)
if (NOT DISABLE_DOCSTRINGS)
target_sources(shiboken2 PRIVATE qtdoc/qtdocgenerator.cpp)
target_compile_definitions(shiboken2 PUBLIC DOCSTRINGS_ENABLED)
@@ -30,7 +30,7 @@ configure_file(shibokenconfig.h.in "${CMAKE_CURRENT_BINARY_DIR}/shibokenconfig.h
install(TARGETS shiboken2
EXPORT Shiboken2Targets
- DESTINATION bin)
+ DESTINATION "${CMAKE_INSTALL_PREFIX}/bin")
set(shiboken_generator_package_name "shiboken2_generator")