aboutsummaryrefslogtreecommitdiffstats
path: root/sources/shiboken2/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sources/shiboken2/tests/CMakeLists.txt')
-rw-r--r--sources/shiboken2/tests/CMakeLists.txt14
1 files changed, 9 insertions, 5 deletions
diff --git a/sources/shiboken2/tests/CMakeLists.txt b/sources/shiboken2/tests/CMakeLists.txt
index 085a4344c..464707a9a 100644
--- a/sources/shiboken2/tests/CMakeLists.txt
+++ b/sources/shiboken2/tests/CMakeLists.txt
@@ -1,3 +1,7 @@
+if(BUILD_TESTS)
+ find_package(Qt5Test 5.12 REQUIRED)
+endif()
+
add_subdirectory(libminimal)
if(NOT DEFINED MINIMAL_TESTS)
add_subdirectory(libsample)
@@ -74,24 +78,24 @@ add_subdirectory(dumpcodemodel)
if (NOT APIEXTRACTOR_DOCSTRINGS_DISABLED)
# project(sphinxtabletest)
-#
+#
# # TODO
# set(sphinxtabletest_SRC sphinxtabletest.cpp)
# qt4_automoc(${sphinxtabletest_SRC})
-#
+#
# include_directories(${QT_INCLUDE_DIR}
# ${QT_QTCORE_INCLUDE_DIR}
# ${CMAKE_CURRENT_BINARY_DIR}
# ${qtdoc_generator_SOURCE_DIR})
-#
+#
# add_executable(sphinxtabletest ${sphinxtabletest_SRC})
-#
+#
# target_link_libraries(sphinxtabletest
# ${QT_QTTEST_LIBRARY}
# ${APIEXTRACTOR_LIBRARY}
# qtdoc_generator
# genrunner)
-#
+#
# add_test("sphinxtable" sphinxtabletest)
# if (INSTALL_TESTS)
# install(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/sphinxtabletest DESTINATION ${TEST_INSTALL_DIR})