aboutsummaryrefslogtreecommitdiffstats
path: root/sources/shiboken2/tests/libsmart/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sources/shiboken2/tests/libsmart/CMakeLists.txt')
-rw-r--r--sources/shiboken2/tests/libsmart/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/sources/shiboken2/tests/libsmart/CMakeLists.txt b/sources/shiboken2/tests/libsmart/CMakeLists.txt
index 66c27cdae..152c57f25 100644
--- a/sources/shiboken2/tests/libsmart/CMakeLists.txt
+++ b/sources/shiboken2/tests/libsmart/CMakeLists.txt
@@ -4,8 +4,8 @@ set(libsmart_SRC
smart.cpp
)
-include_directories(${CMAKE_CURRENT_SOURCE_DIR})
-add_definitions("-DLIBSMART_BUILD")
add_library(libsmart SHARED ${libsmart_SRC})
+target_include_directories(libsmart PUBLIC ${CMAKE_CURRENT_SOURCE_DIR})
+target_compile_definitions(libsmart PRIVATE LIBSMART_BUILD)
set_property(TARGET libsmart PROPERTY PREFIX "")