aboutsummaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
new file mode 100644
index 000000000..0d28c4419
--- /dev/null
+++ b/tests/CMakeLists.txt
@@ -0,0 +1,20 @@
+project(sphinxtabletest)
+
+# TODO
+set(sphinxtabletest_SRC sphinxtabletest.cpp)
+qt4_automoc(${sphinxtabletest_SRC})
+
+include_directories(${QT_INCLUDE_DIR}
+ ${QT_QTCORE_INCLUDE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${qtdoc_generator_SOURCE_DIR})
+
+add_executable(sphinxtabletest ${sphinxtabletest_SRC})
+
+target_link_libraries(sphinxtabletest
+ ${QT_QTTEST_LIBRARY}
+ ${APIEXTRACTOR_LIBRARY}
+ qtdoc_generator
+ genrunner)
+
+add_test("sphinxtable" sphinxtabletest)