aboutsummaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 1f123bf72..b8facb001 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -1,3 +1,10 @@
+if(CMAKE_VERSION VERSION_LESS 2.8)
+ # Versions lesser than 2.8 can not set environment variables for tests.
+ message("CMake version greater than 2.8 necessary to run certain tests.")
+else()
+ add_subdirectory(test_generator)
+endif()
+
if (NOT APIEXTRACTOR_DOCSTRINGS_DISABLED)
project(sphinxtabletest)