aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHugo Parente Lima <hugo.lima@openbossa.org>2010-05-20 16:05:32 -0300
committerHugo Parente Lima <hugo.lima@openbossa.org>2010-05-20 17:27:30 -0300
commit6f8c06d6cb031fae154f0ae1094a3c4a425e9a92 (patch)
tree4a6547dde553e7b7acefc8c7c2c5eb8a0d5f6b32 /CMakeLists.txt
parent25d80b305292ab66d76246f1135d1f19126b762b (diff)
Fix bug#205 - "pyside-uic doesn't really give a version number"
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c1f6c01..5d3dd49 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,6 +12,8 @@ set(pyside_tools_MINOR_VERSION "1")
set(pyside_tools_MICRO_VERSION "3")
set(pyside_tools_VERSION "${pyside_tools_MAJOR_VERSION}.${pyside_tools_MINOR_VERSION}.${pyside_tools_MICRO_VERSION}")
+configure_file(pyside-uic.in pyside-uic @ONLY)
+
# UIC stuff
execute_process(
COMMAND ${PYTHON_EXECUTABLE} -c "from distutils import sysconfig; \\
@@ -20,9 +22,9 @@ execute_process(
OUTPUT_STRIP_TRAILING_WHITESPACE)
if (NOT SITE_PACKAGE)
message(FATAL_ERROR "Could not detect Python module installation directory.")
-endif (NOT SITE_PACKAGE)
+endif()
-install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/pyside-uic
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/pyside-uic
DESTINATION bin
PERMISSIONS
OWNER_EXECUTE OWNER_WRITE OWNER_READ