aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7be3488..561ba82 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -43,6 +43,12 @@ install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/pyside2-uic
GROUP_EXECUTE GROUP_READ
WORLD_EXECUTE WORLD_READ)
+# on win32 we cannot rely on the shebang for the shell to interpret the pyside2-uic command
+if (WIN32)
+ file (WRITE ${CMAKE_CURRENT_BINARY_DIR}/pyside2-uic.bat "python %~dp0pyside2-uic %*\n")
+ install (FILES ${CMAKE_CURRENT_BINARY_DIR}/pyside2-uic.bat DESTINATION bin)
+endif ()
+
install(FILES "${CMAKE_CURRENT_BINARY_DIR}/pyside2uic/__init__.py"
DESTINATION "${SITE_PACKAGE}/pyside2uic")
install(DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/pyside2uic