aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 8 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d328654..5bb2f9c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -43,12 +43,6 @@ install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/pyside2-uic
GROUP_EXECUTE GROUP_READ
WORLD_EXECUTE WORLD_READ)
-# on win32 we cannot rely on the shebang for the shell to interpret the pyside2-uic command
-if (WIN32)
- file (WRITE ${CMAKE_CURRENT_BINARY_DIR}/pyside2-uic.bat "python %~dp0pyside2-uic %*\n")
- install (FILES ${CMAKE_CURRENT_BINARY_DIR}/pyside2-uic.bat DESTINATION bin)
-endif ()
-
install(FILES "${CMAKE_CURRENT_BINARY_DIR}/pyside2uic/__init__.py"
DESTINATION "${SITE_PACKAGE}/pyside2uic")
install(DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/pyside2uic
@@ -85,6 +79,14 @@ set(PYSIDE2RCC_EXECUTABLE ${CMAKE_CURRENT_BINARY_DIR}/pyrcc/pyside2-rcc)
add_subdirectory(pyrcc)
add_subdirectory(pylupdate)
+# pyside2-rcc, shiboken and pyside2-lupdate entrypoints
+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/pyside_tool.py
+ DESTINATION bin
+ PERMISSIONS
+ OWNER_EXECUTE OWNER_WRITE OWNER_READ
+ GROUP_EXECUTE GROUP_READ
+ WORLD_EXECUTE WORLD_READ)
+
if (BUILD_TESTS)
enable_testing()
add_subdirectory(tests)