aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEike Ziller <eike.ziller@qt.io>2021-01-13 08:31:41 +0100
committerEike Ziller <eike.ziller@qt.io>2021-01-13 09:46:33 +0000
commit01a8b6e11986a3260e911e6a95a0d85d17467c49 (patch)
tree36cc77364f0ccee1e23faf59386f2784a0ba4b51 /CMakeLists.txt
parent8621465db2c7fa10eb014ef14d55ec7dd3e085a0 (diff)
cmake build: Turn project file updates on by default
Project file updates should be supported by any qbs binary, since nowadays IDE integration is not tied to a special build of Qbs. Task-number: QTCREATORBUG-25232 Change-Id: Ic2fe6b0ecdb77d84209ce16fdfe8158334a8bb29 Reviewed-by: Christian Kandeler <christian.kandeler@qt.io> Reviewed-by: Ivan Komissarov <ABBAPOH@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d23ddf8cc..f6a87d10d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,7 +24,7 @@ set(CMAKE_AUTOUIC ON)
option(WITH_TESTS "Build Tests" ON)
option(WITH_UNIT_TESTS "Build Unit Tests" OFF)
-option(WITH_PROJECT_FILE_UPDATES "Enable project file updates support" OFF)
+option(WITH_PROJECT_FILE_UPDATES "Enable project file updates support" ON)
option(INSTALL_PUBLIC_HEADERS "Whether to install public headers" ON)
option(QBS_INSTALL_HTML_DOCS "Whether to install HTML Documentation" OFF)
option(QBS_INSTALL_QCH_DOCS "Whether to install QCH Documentation" OFF)