aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEike Ziller <eike.ziller@qt.io>2020-10-20 10:37:22 +0200
committerEike Ziller <eike.ziller@qt.io>2020-10-20 12:26:38 +0000
commitd870a7a4535e801e1161ececccd0d85dca0a3408 (patch)
tree665413c9a4e5f2e22118ff86b8528d464d1015e6 /CMakeLists.txt
parentfb88a018ef7c2efd0758018bd1697d21561c4b3c (diff)
cmake: Remove ccache magic
Setting the compiler/linker prefix globally heavily interferes with other setups. For example it breaks compiling resources with rc.exe on Windows. Use CMAKE_C_COMPILER_LAUNCHER=ccache and CMAKE_CXX_COMPILER_LAUNCHER=ccache when calling cmake instead. Change-Id: Id7fa7a3ce8b19b658eee0b661c9dfa060c3d62c9 Reviewed-by: Cristian Adam <cristian.adam@qt.io> Reviewed-by: Ivan Komissarov <ABBAPOH@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 0 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2d3376b15..18b8c7fc7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -27,12 +27,6 @@ option(WITH_UNIT_TESTS "Build Unit Tests" OFF)
option(WITH_PROJECT_FILE_UPDATES "Enable project file updates support" OFF)
option(INSTALL_PUBLIC_HEADERS "Whether to install public headers" ON)
-find_program(CCACHE_FOUND ccache)
-if(CCACHE_FOUND)
- set_property(GLOBAL PROPERTY RULE_LAUNCH_COMPILE ccache)
- set_property(GLOBAL PROPERTY RULE_LAUNCH_LINK ccache) # Less useful to do it for linking, see edit2
-endif(CCACHE_FOUND)
-
if(WITH_TESTS)
enable_testing()
set(QT_TEST_COMPONENT Test)