aboutsummaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Kandeler <christian.kandeler@qt.io>2023-10-18 14:10:54 +0200
committerChristian Kandeler <christian.kandeler@qt.io>2023-11-07 11:36:49 +0000
commit0a6b84989775c0a9054ee5167212454da09c416f (patch)
tree4d1d503abe5c366546d74f79126eab9f8cc8f71a /tests/CMakeLists.txt
parent1490cf65966007ec7564475da9d606d3ae6475fc (diff)
Add an LSP server
This provides IDE-agnostic tooling via the Language Server Protocol (https://microsoft.github.io/language-server-protocol). The protocol implementation is taken from Qt Creator, plus a minimal set of dependencies. For now, our server provides only the "Goto definition" capability, which allows IDE users to click on a Depends item and get to the corresponding module or product. Task-number: QBS-395 Change-Id: Ia444aa7a6d1c114e4fd456098c74134ccdaadcec Reviewed-by: Ivan Komissarov <ABBAPOH@gmail.com>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 3a868fbac..55dcad789 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -1,3 +1,4 @@
add_subdirectory(auto)
add_subdirectory(benchmarker)
add_subdirectory(fuzzy-test)
+add_subdirectory(lspclient)