aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/blackbox/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Kandeler <christian.kandeler@qt.io>2022-09-22 17:14:55 +0200
committerChristian Kandeler <christian.kandeler@qt.io>2022-10-04 07:43:01 +0000
commita29bbf5568bf651b076f051720a98e9d0297faa9 (patch)
tree5d99c12c7d9735e7f113c3a04ccf95746ef8dedc /tests/auto/blackbox/CMakeLists.txt
parent512001849af89e4b2c5bfb18b039387d6fe7aaa6 (diff)
Make handling of deprecated items and properties configurable
As of now, a newly deprecated property leads to users getting bombarded with warnings, even though they did not yet have a chance to adapt their project. Now the warnings appear by default one minor version before removal, which together with our convention of keeping deprecated properties for at least two minor versions gives users enough time to adapt without getting spammed. There is also a mode for switching to the previous behavior (for early detection), as well as the possibility to trigger errors instead of warnings, which should be helpful in CI configurations. To support the case where the user cannot do anything about them, the warnings can also be suppressed altogether. Change-Id: I295f816758f0f111fcb0351581a4328be3af5668 Reviewed-by: Leena Miettinen <riitta-leena.miettinen@qt.io> Reviewed-by: Ivan Komissarov <ABBAPOH@gmail.com>
Diffstat (limited to 'tests/auto/blackbox/CMakeLists.txt')
-rw-r--r--tests/auto/blackbox/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/auto/blackbox/CMakeLists.txt b/tests/auto/blackbox/CMakeLists.txt
index 0bf79a433..5b5376064 100644
--- a/tests/auto/blackbox/CMakeLists.txt
+++ b/tests/auto/blackbox/CMakeLists.txt
@@ -1,6 +1,7 @@
add_qbs_test(blackbox
DEFINES
${QBS_UNIT_TESTS_DEFINES}
+ "QBS_VERSION=\"${QBS_VERSION}\""
SOURCES
../shared.h
tst_blackboxbase.cpp