aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorIvan Komissarov <ABBAPOH@gmail.com>2020-08-13 00:45:36 +0200
committerIvan Komissarov <ABBAPOH@gmail.com>2020-08-17 17:09:39 +0000
commitb67b08f1c2c26a226db6f43f2452026f85ad6460 (patch)
treee8aa41c51e6247919d531d9cd35737c98a360ff9 /tests/auto/tools/CMakeLists.txt
parent2311a8224c3fc7141c44cc517f4ecdb882cd09f8 (diff)
Initial CMake port
This change allows to build Qbs using CMake build tool Tested platforms - Linux (gcc) - macOS (clang) - Windows (msvc2017) Missing features (compared to Qbs build) - Documentation build - Bundled QtScript support - Static build - .pc file for qbscore - qbs module for qbscore Change-Id: I09b5dadd6723d5a47e5ef2a9a38d3300488718f2 Reviewed-by: Christian Kandeler <christian.kandeler@qt.io>
Diffstat (limited to 'tests/auto/tools/CMakeLists.txt')
-rw-r--r--tests/auto/tools/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/auto/tools/CMakeLists.txt b/tests/auto/tools/CMakeLists.txt
new file mode 100644
index 000000000..a75d998a3
--- /dev/null
+++ b/tests/auto/tools/CMakeLists.txt
@@ -0,0 +1,7 @@
+add_qbs_test(tools
+ DEFINES
+ "QBS_VERSION=\"${QBS_VERSION}\""
+ SOURCES
+ tst_tools.cpp
+ tst_tools.h
+ )