aboutsummaryrefslogtreecommitdiffstats
path: root/src/lib/corelib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/lib/corelib/CMakeLists.txt')
-rw-r--r--src/lib/corelib/CMakeLists.txt79
1 files changed, 49 insertions, 30 deletions
diff --git a/src/lib/corelib/CMakeLists.txt b/src/lib/corelib/CMakeLists.txt
index a6efd0ff3..97b5e6fad 100644
--- a/src/lib/corelib/CMakeLists.txt
+++ b/src/lib/corelib/CMakeLists.txt
@@ -110,7 +110,6 @@ set(BUILD_GRAPH_SOURCES
rulesapplicator.h
rulesevaluationcontext.cpp
rulesevaluationcontext.h
- scriptclasspropertyiterator.h
timestampsupdater.cpp
timestampsupdater.h
transformer.cpp
@@ -172,7 +171,6 @@ list_transform_prepend(JS_EXTENSIONS_SOURCES jsextensions/)
if(APPLE)
set(JS_EXTENSIONS_MACOS_SOURCES
- propertylist_darwin.h
propertylist_darwin.mm
propertylistutils.h
propertylistutils.mm
@@ -185,20 +183,13 @@ list_transform_prepend(JS_EXTENSIONS_MACOS_SOURCES jsextensions/)
set(LANGUAGE_SOURCES
artifactproperties.cpp
artifactproperties.h
- astimportshandler.cpp
- astimportshandler.h
- astpropertiesitemhandler.cpp
- astpropertiesitemhandler.h
asttools.cpp
asttools.h
builtindeclarations.cpp
builtindeclarations.h
deprecationinfo.h
- evaluationdata.h
evaluator.cpp
evaluator.h
- evaluatorscriptclass.cpp
- evaluatorscriptclass.h
filecontext.cpp
filecontext.h
filecontextbase.cpp
@@ -214,31 +205,13 @@ set(LANGUAGE_SOURCES
itemobserver.h
itempool.cpp
itempool.h
- itemreader.cpp
- itemreader.h
- itemreaderastvisitor.cpp
- itemreaderastvisitor.h
- itemreadervisitorstate.cpp
- itemreadervisitorstate.h
itemtype.h
jsimports.h
language.cpp
language.h
- loader.cpp
- loader.h
- moduleloader.cpp
- moduleloader.h
- modulemerger.cpp
- modulemerger.h
moduleproviderinfo.h
- moduleproviderloader.cpp
- moduleproviderloader.h
preparescriptobserver.cpp
preparescriptobserver.h
- probesresolver.cpp
- probesresolver.h
- projectresolver.cpp
- projectresolver.h
property.cpp
property.h
propertydeclaration.cpp
@@ -262,6 +235,48 @@ list_transform_prepend(LANGUAGE_SOURCES language/)
set(LANGUAGE_HEADERS language/forward_decls.h)
+set(LOADER_SOURCES
+ astimportshandler.cpp
+ astimportshandler.h
+ astpropertiesitemhandler.cpp
+ astpropertiesitemhandler.h
+ dependenciesresolver.cpp
+ dependenciesresolver.h
+ groupshandler.cpp
+ groupshandler.h
+ itemreader.cpp
+ itemreader.h
+ itemreaderastvisitor.cpp
+ itemreaderastvisitor.h
+ itemreadervisitorstate.cpp
+ itemreadervisitorstate.h
+ loaderutils.cpp
+ loaderutils.h
+ localprofiles.cpp
+ localprofiles.h
+ moduleinstantiator.cpp
+ moduleinstantiator.h
+ moduleloader.cpp
+ moduleloader.h
+ modulepropertymerger.cpp
+ modulepropertymerger.h
+ moduleproviderloader.cpp
+ moduleproviderloader.h
+ probesresolver.cpp
+ probesresolver.h
+ productitemmultiplexer.cpp
+ productitemmultiplexer.h
+ productresolver.cpp
+ productresolver.h
+ productscollector.cpp
+ productscollector.h
+ productsresolver.cpp
+ productsresolver.h
+ projectresolver.cpp
+ projectresolver.h
+ )
+list_transform_prepend(LOADER_SOURCES loader/)
+
set(LOGGING_SOURCES
categories.cpp
categories.h
@@ -306,6 +321,7 @@ set(TOOLS_SOURCES
cleanoptions.cpp
codelocation.cpp
commandechomode.cpp
+ deprecationwarningmode.cpp
dynamictypecheck.h
error.cpp
executablefinder.cpp
@@ -335,6 +351,7 @@ set(TOOLS_SOURCES
msvcinfo.cpp
msvcinfo.h
pathutils.h
+ pimpl.h
persistence.cpp
persistence.h
porting.h
@@ -349,6 +366,7 @@ set(TOOLS_SOURCES
progressobserver.cpp
progressobserver.h
projectgeneratormanager.cpp
+ propagate_const.h
qbsassert.cpp
qbsassert.h
qbspluginmanager.cpp
@@ -389,10 +407,12 @@ set(TOOLS_HEADERS
cleanoptions.h
codelocation.h
commandechomode.h
+ deprecationwarningmode.h
error.h
generateoptions.h
installoptions.h
joblimits.h
+ mutexdata.h
preferences.h
processresult.h
profile.h
@@ -433,7 +453,7 @@ add_qbs_library(qbscore
Qt${QT_VERSION_MAJOR}::Xml
Qt6Core5Compat
qbspkgconfig
- qbsscriptengine
+ qbsquickjs
PUBLIC_DEPENDS
Qt${QT_VERSION_MAJOR}::Core
${EXTERNAL_DEPENDS}
@@ -452,6 +472,7 @@ add_qbs_library(qbscore
${JS_EXTENSIONS_MACOS_SOURCES}
${LANGUAGE_SOURCES}
${LANGUAGE_HEADERS}
+ ${LOADER_SOURCES}
${LOGGING_SOURCES}
${LOGGING_HEADERS}
${PARSER_SOURCES}
@@ -469,6 +490,4 @@ if(INSTALL_PUBLIC_HEADERS)
install(FILES ${LOGGING_HEADERS} DESTINATION ${QBS_HEADERS_INSTALL_DIR}/logging)
install(FILES ${LANGUAGE_HEADERS} DESTINATION ${QBS_HEADERS_INSTALL_DIR}/language)
install(FILES ${TOOLS_HEADERS} DESTINATION ${QBS_HEADERS_INSTALL_DIR}/tools)
- set(QMAKE_PRI_FILES use_installed_corelib.pri ../../../qbs_version.pri)
- install(FILES ${QMAKE_PRI_FILES} DESTINATION ${QBS_HEADERS_INSTALL_DIR})
endif()