aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/scanner/cpp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/scanner/cpp/CMakeLists.txt')
-rw-r--r--src/plugins/scanner/cpp/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/plugins/scanner/cpp/CMakeLists.txt b/src/plugins/scanner/cpp/CMakeLists.txt
new file mode 100644
index 000000000..b394dd74d
--- /dev/null
+++ b/src/plugins/scanner/cpp/CMakeLists.txt
@@ -0,0 +1,16 @@
+set(SOURCES
+ ../scanner.h
+ CPlusPlusForwardDeclarations.h
+ Lexer.cpp
+ Lexer.h
+ Token.cpp
+ Token.h
+ cpp_global.h
+ cppscanner.cpp
+ )
+
+add_qbs_plugin(qbs_cpp_scanner
+ DEFINES "CPLUSPLUS_NO_PARSER"
+ DEPENDS corelib
+ SOURCES ${SOURCES}
+ )