summaryrefslogtreecommitdiffstats
path: root/startupscreen/CMakeLists.txt
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2020-10-23 15:32:54 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2020-10-29 05:43:55 +0000
commit31a633bc93eb2eaff4d50596c69db0ad83a3e6cf (patch)
tree754e90145a71900cbf24888a6d676afca6d591ae /startupscreen/CMakeLists.txt
parent25842566eee73aa8f2b07dcd334d47d6f6853579 (diff)
startupscreen: enable usb mode switch
The USB button can be used switch the USB Ethernet driver mode between cdcecm and rndis to work with Linux, Windows and macOS host machines. Task-number: QTBUG-87857 Change-Id: Iab54d7582bdd9c39fca95dfa0bb8637d5ea14e81 Reviewed-by: Rami Potinkara <rami.potinkara@qt.io>
Diffstat (limited to 'startupscreen/CMakeLists.txt')
-rw-r--r--startupscreen/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/startupscreen/CMakeLists.txt b/startupscreen/CMakeLists.txt
index 3b9bdf9..87b0238 100644
--- a/startupscreen/CMakeLists.txt
+++ b/startupscreen/CMakeLists.txt
@@ -11,11 +11,12 @@ set(CMAKE_AUTORCC ON)
set(CMAKE_CXX_STANDARD 11)
set(CMAKE_CXX_STANDARD_REQUIRED ON)
-find_package(QT NAMES Qt6 Qt5 COMPONENTS Core Quick REQUIRED)
-find_package(Qt${QT_VERSION_MAJOR} COMPONENTS Core Quick REQUIRED)
+find_package(QT NAMES Qt6 Qt5 COMPONENTS Core Quick QuickControls2 REQUIRED)
+find_package(Qt${QT_VERSION_MAJOR} COMPONENTS Core Quick QuickControls2 REQUIRED)
add_executable(startupscreen
main.cpp
+ settingsmanager.cpp
qml.qrc
)