summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..d3c8839
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,36 @@
+# Copyright (C) 2023 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+cmake_minimum_required(VERSION 3.16)
+
+include(.cmake.conf)
+project(QtAutoDeploymentServer
+ VERSION "${QT_REPO_MODULE_VERSION}"
+ DESCRIPTION "QtAuto deployment server"
+ HOMEPAGE_URL "https://qt.io/"
+ LANGUAGES CXX C
+)
+
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Network)
+
+add_custom_target(create_docker
+ COMMAND docker build -t qtauto-deployment-server .
+ WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}
+ VERBATIM
+)
+
+qt_build_repo()
+
+
+if(QT_BUILD_ONLINE_DOCS)
+ set(DOC_CONF "doc/online/qtautodeploymentserver.qdocconf")
+else()
+ set(DOC_CONF "doc/qtautodeploymentserver.qdocconf")
+endif()
+
+file(GLOB_RECURSE allDocFiles "doc/*.qdoc" "doc/*.png" "doc/*.qdocconf")
+add_custom_target(Documentation SOURCES ${allDocFiles})
+qt_internal_add_docs(Documentation ${DOC_CONF})
+
+# Add tool dependencies that were deferred by qt_internal_add_docs.
+qt_internal_add_deferred_dependencies()