summaryrefslogtreecommitdiffstats
path: root/config/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'config/Makefile.am')
-rw-r--r--config/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/config/Makefile.am b/config/Makefile.am
index 66012d02..9d292cee 100644
--- a/config/Makefile.am
+++ b/config/Makefile.am
@@ -38,9 +38,9 @@ if MAINTAINER_MODE
$(srcdir)/elfutils.spec.in: $(top_srcdir)/NEWS
@tmpname=$$(mktemp $${TMPDIR:-/tmp}/elfutils.XXXXXX); \
date +'* %a %b %e %Y' | tr '[\n]' '[ ]' > $$tmpname; \
- getent passwd "$$(whoami)" | \
- awk 'BEGIN {FS=":"} { printf $$5; exit 0}' >> $$tmpname; \
- echo -n " <$$(whoami)@gmail.com> " >> $$tmpname; \
+ username=$$(git config --get user.name); \
+ useremail=$$(git config --get user.email); \
+ echo -n "$$username <$$useremail> " >> $$tmpname; \
awk '\
$$1 == "Version" && started { exit } \
$$1 == "Version" { started=1; line=""; sub(/:/,"",$$2); \