summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 17 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index b351f086..eddacb8b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -125,11 +125,11 @@ AS_HELP_STRING([--enable-gnulib],
use_gnulib=$enableval, use_gnulib=no)
AM_CONDITIONAL(USE_GNULIB, test "$use_gnulib" = yes)
-AC_ARG_ENABLE([selfcontained],
-AS_HELP_STRING([--enable-selfcontained],
- [install extra headers to enable including and linking the libraries on non-GNU systems]),
- selfcontained=$enableval, selfcontained=no)
-AM_CONDITIONAL(SELFCONTAINED, test "$selfcontained" = yes)
+AC_ARG_ENABLE([install-featuresh],
+AS_HELP_STRING([--enable-install-featuresh],
+ [install a dummy features.h header]),
+ install_featuresh=$enableval, install_featuresh=no)
+AM_CONDITIONAL(INSTALL_FEATURESH, test "$install_featuresh" = yes)
AC_PROG_CC
@@ -389,6 +389,11 @@ if test "$use_valgrind" = yes; then
fi
AM_CONDITIONAL(USE_VALGRIND, test "$use_valgrind" = yes)
+AC_ARG_ENABLE([install-elfh],
+AS_HELP_STRING([--enable-install-elfh],[install elf.h in include dir]),
+ [install_elfh=$enableval], [install_elfh=no])
+AM_CONDITIONAL(INSTALL_ELFH, test "$install_elfh" = yes)
+
AM_CONDITIONAL(BUILD_STATIC, [dnl
test "$use_gprof" = yes -o "$use_gcov" = yes])
@@ -811,6 +816,7 @@ AC_MSG_NOTICE([
NOT RECOMMENDED FEATURES (should all be no)
Experimental thread safety : ${use_locks}
+ install elf.h : ${install_elfh}
OTHER FEATURES
Deterministic archives by default : ${default_ar_deterministic}
@@ -826,3 +832,9 @@ AC_MSG_NOTICE([
use rpath in tests : ${tests_use_rpath}
test biarch : ${utrace_cv_cc_biarch}
])
+
+if test "$install_elfh" = yes; then
+ if test "${prefix}" = "/usr/local" -o "${prefix}" = "/usr"; then
+ AC_MSG_WARN([installing elf.h in ${includedir} might conflict with glibc/system elf.h])
+ fi
+fi