summaryrefslogtreecommitdiffstats
path: root/libelf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libelf/Makefile.am')
-rw-r--r--libelf/Makefile.am20
1 files changed, 10 insertions, 10 deletions
diff --git a/libelf/Makefile.am b/libelf/Makefile.am
index 015a07e3..9d6da6b4 100644
--- a/libelf/Makefile.am
+++ b/libelf/Makefile.am
@@ -38,6 +38,16 @@ noinst_LIBRARIES = libelf_pic.a
noinst_DATA = $(libelf_BARE)
include_HEADERS = libelf.h gelf.h nlist.h
+noinst_HEADERS = abstract.h common.h exttypes.h gelf_xlate.h libelfP.h \
+ version_xlate.h gnuhash_xlate.h note_xlate.h dl-hash.h \
+ chdr_xlate.h
+
+if INSTALL_ELFH
+include_HEADERS += elf.h
+else
+noinst_HEADERS += elf.h
+endif
+
pkginclude_HEADERS = elf-knowledge.h
libelf_a_SOURCES = elf_version.c elf_hash.c elf_error.c elf_fill.c \
@@ -149,16 +159,6 @@ endif
install: install-am install-lib
uninstall: uninstall-am uninstall-lib
-noinst_HEADERS = abstract.h common.h exttypes.h gelf_xlate.h libelfP.h \
- version_xlate.h gnuhash_xlate.h note_xlate.h dl-hash.h \
- chdr_xlate.h
-
-if SELFCONTAINED
-include_HEADERS += elf.h
-else
-noinst_HEADERS += elf.h
-endif
-
EXTRA_DIST = libelf.map
CLEANFILES += $(am_libelf_pic_a_OBJECTS) $(libelf_SONAME) $(libelf_BARE)