summaryrefslogtreecommitdiffstats
path: root/libgnu/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libgnu/Makefile.am')
-rw-r--r--libgnu/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/libgnu/Makefile.am b/libgnu/Makefile.am
index 05a8f615..d7af59a1 100644
--- a/libgnu/Makefile.am
+++ b/libgnu/Makefile.am
@@ -35,7 +35,7 @@ noinst_LIBRARIES =
MOSTLYCLEANFILES =
MOSTLYCLEANDIRS =
BUILT_SOURCES =
-EXTRA_DIST = endian.in.h byteswap.in.h sys_mman.win32.h mman_win32.c sysconf_win32.c
+EXTRA_DIST = endian.in.h byteswap.in.h sys_mman.win32.h mman_win32.c sysconf_win32.c ar.in.h
CLEANFILES =
SUFFIXES =
@@ -53,6 +53,13 @@ BUILT_SOURCES += byteswap.h
MOSTLYCLEANFILES += byteswap.h
endif
+if !HAVE_AR_H
+ar.h: ar.in.h
+ $(AM_V_GEN)rm -f $@ && cat $< > $@
+BUILT_SOURCES += ar.h
+MOSTLYCLEANFILES += ar.h
+endif
+
if !HAVE_SYS_MMAN_H
if USE_WIN32_MMAN
sys/mman.h: sys_mman.win32.h