summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am10
1 files changed, 4 insertions, 6 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index d60d6636..4b88e16d 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -608,14 +608,12 @@ next_cfi_LDADD = $(libelf) $(libdw) $(libgnu)
elfcopy_LDADD = $(libelf) $(libgnu)
addsections_LDADD = $(libelf) $(libgnu)
-if SELFCONTAINED
-# In self contained mode we cannot expect a system elf header.
-# Use our own then
-system_elf_libelf_test_CPPFLAGS = -I$(top_srcdir)/libelf
-else
# We want to test the libelf header against the system elf.h header.
-# Don't include any -I CPPFLAGS.
+# Don't include any -I CPPFLAGS. Except when we install our own elf.h.
+if !INSTALL_ELFH
system_elf_libelf_test_CPPFLAGS =
+else
+system_elf_libelf_test_CPPFLAGS = -I$(top_srcdir)/libelf
endif
if USE_GNULIB
system_elf_libelf_test_CPPFLAGS += -I$(top_srcdir)/libgnu -I$(top_builddir)/libgnu