aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/haskell/CMakeLists.txt
diff options
context:
space:
mode:
authorEike Ziller <eike.ziller@qt.io>2019-08-19 09:30:39 +0200
committerEike Ziller <eike.ziller@qt.io>2019-08-19 12:03:21 +0000
commit8ff9ef68a0274822b6c5e10b37f050579be3839e (patch)
tree32a2f9bfb878d5576dd9da0c43c18a1eda0a11dd /plugins/haskell/CMakeLists.txt
parent4291fcd8b3cc4e5bcfe04f7e54ea02f6231737cc (diff)
Add cmake build files4.10
Change-Id: I6152e54c47cf0c07d3c415d38fc39b859bcf65de Reviewed-by: Cristian Adam <cristian.adam@qt.io> Reviewed-by: Eike Ziller <eike.ziller@qt.io>
Diffstat (limited to 'plugins/haskell/CMakeLists.txt')
-rw-r--r--plugins/haskell/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/plugins/haskell/CMakeLists.txt b/plugins/haskell/CMakeLists.txt
new file mode 100644
index 0000000..d2e08af
--- /dev/null
+++ b/plugins/haskell/CMakeLists.txt
@@ -0,0 +1,29 @@
+find_package(QtCreator COMPONENTS Core TextEditor ProjectExplorer REQUIRED)
+find_package(Qt5 COMPONENTS Widgets REQUIRED)
+
+add_qtc_plugin(Haskell
+ PLUGIN_DEPENDS
+ QtCreator::Core QtCreator::TextEditor QtCreator::ProjectExplorer
+ DEPENDS Qt5::Widgets
+ SOURCES
+ filecache.cpp filecache.h
+ followsymbol.cpp followsymbol.h
+ ghcmod.cpp ghcmod.h
+ haskell.qrc
+ haskell_global.h
+ haskellbuildconfiguration.cpp haskellbuildconfiguration.h
+ haskellcompletionassist.cpp haskellcompletionassist.h
+ haskellconstants.h
+ haskelldocument.cpp haskelldocument.h
+ haskelleditorfactory.cpp haskelleditorfactory.h
+ haskelleditorwidget.cpp haskelleditorwidget.h
+ haskellhighlighter.cpp haskellhighlighter.h
+ haskellhoverhandler.cpp haskellhoverhandler.h
+ haskellmanager.cpp haskellmanager.h
+ haskellplugin.cpp haskellplugin.h
+ haskellproject.cpp haskellproject.h
+ haskellrunconfiguration.cpp haskellrunconfiguration.h
+ haskelltokenizer.cpp haskelltokenizer.h
+ optionspage.cpp optionspage.h
+ stackbuildstep.cpp stackbuildstep.h
+)