aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEike Ziller <eike.ziller@qt.io>2020-09-03 13:36:44 +0200
committerEike Ziller <eike.ziller@qt.io>2020-09-03 12:11:34 +0000
commit0ceb9f487c64b06a2298d0cff1186a3c6d0d0001 (patch)
treebd6337e8a4c3cd44eb960efaa344bf54cd28daa4 /CMakeLists.txt
parent9c09d822514c6f1d7008c6c7457649d3532722f3 (diff)
CMake build: Check minimum Qt version
Change-Id: I81244c2480d647a2cf48885b2a125a02b11767b4 Reviewed-by: Cristian Adam <cristian.adam@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 48770a5483..1282fe6206 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,6 +7,7 @@ include(FeatureSummary)
include(QtCreatorIDEBranding)
include(QtCreatorTranslations)
include(QtCreatorDocumentation)
+include(QtCreatorAPI)
set(IDE_REVISION FALSE CACHE BOOL "Marks the presence of IDE revision string.")
set(IDE_REVISION_STR "" CACHE STRING "The IDE revision string.")
@@ -39,6 +40,7 @@ if (WITH_TESTS)
endif()
find_package(Qt5
+ ${IDE_QT_VERSION_MIN}
COMPONENTS Concurrent Core Gui Network PrintSupport Qml Quick
QuickWidgets Sql Widgets Xml ${QT_TEST_COMPONENT}
REQUIRED
@@ -85,8 +87,6 @@ if (APPLE)
find_library(FWWebKit WebKit)
endif()
-include(QtCreatorAPI)
-
if (WITH_TESTS)
enable_testing()
endif()