aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEike Ziller <eike.ziller@qt.io>2020-03-19 16:02:44 +0100
committerEike Ziller <eike.ziller@qt.io>2020-03-23 07:14:27 +0000
commit9eceb46739803bb7482e9017cd79df92203ecbad (patch)
treea5225bc4dd9bec174a8636f88a6f3e805bd2c420 /CMakeLists.txt
parent549b2f60924aafdb9b3f22bdbcd7870afe3ae172 (diff)
Fix link on commit sha in about dialog
Passing a URL via defines breaks when trying to "stringify" it. It would always stop at the first slash. Instead use a qmake variable directly. That has the additional advantage that the value isn't passed on each and every compiler command line. Change-Id: I97a297fbcdee5ea03eb6fa08181c95b1ad2de767 Reviewed-by: Cristian Adam <cristian.adam@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cb79a450f0..9cf66c74aa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,9 +8,9 @@ include(QtCreatorIDEBranding)
set(IDE_REVISION FALSE CACHE BOOL "Marks the presence of IDE revision string.")
set(IDE_REVISION_STR "" CACHE STRING "The IDE revision string.")
-set(IDE_REVISION_URL_STR "" CACHE STRING "The IDE revision Url string.")
+set(IDE_REVISION_URL "" CACHE STRING "The IDE revision Url string.")
-mark_as_advanced(IDE_REVISION IDE_REVISION_STR IDE_REVISION_URL_STR)
+mark_as_advanced(IDE_REVISION IDE_REVISION_STR IDE_REVISION_URL)
project(QtCreator VERSION ${IDE_VERSION})