aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Hunger <tobias.hunger@qt.io>2019-11-13 13:31:21 +0100
committerTobias Hunger <tobias.hunger@qt.io>2019-11-13 16:08:41 +0000
commitb0fb6537f9f1f226e6256cda05c0d8a6ef30ef02 (patch)
tree2e33b2162d1fe95ecdc9fd85d44ff936483fcf26 /CMakeLists.txt
parentad754d93ca8d43d970a2ad5fb0616ef31a2b0e73 (diff)
CMake: Do not require Qt LinguistTools
They are only used optionally for the translations, so there is no need to require those. Change-Id: I9f84e0d62f7075394e9f260c11746e4327e60995 Reviewed-by: Alessandro Portale <alessandro.portale@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e29d793d7f..5f42e82315 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -35,11 +35,13 @@ if (WITH_TESTS)
endif()
find_package(Qt5
- COMPONENTS Concurrent Core Gui LinguistTools Network PrintSupport Qml Quick
+ COMPONENTS Concurrent Core Gui Network PrintSupport Qml Quick
QuickWidgets Sql Widgets Xml ${QT_TEST_COMPONENT}
REQUIRED
)
+find_package(Qt5 COMPONENTS LinguistTools)
+
find_package(Threads)
# Get information on directories from qmake