aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCristian Adam <cristian.adam@gmail.com>2019-06-03 13:23:10 +0200
committerCristian Adam <cristian.adam@qt.io>2019-06-03 11:49:13 +0000
commitdfe38f79c3aa7a1ebcf4d90792bc2a297d1b6dfa (patch)
treea9a74c476808122f84ddef974d9442588318884a /CMakeLists.txt
parentd1fef0ea517a163003a26edd8ba89b33f05d64dc (diff)
CMake build: Ensure compilation when Qt5::Script is missing
The Qt5 Visual C++ 2017 64 bit installation doesn't come with Qt5::Script target by default. This patch ensures that Qt Creator can be built with the above Qt5 scenario. Change-Id: Ibe35e9d879ccd51012f53acebfbb7461fd773d4a Reviewed-by: Eike Ziller <eike.ziller@qt.io> Reviewed-by: Alessandro Portale <alessandro.portale@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b3a256ae9a..353cf93d53 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -50,7 +50,7 @@ endif()
find_package(Qt5
COMPONENTS Concurrent Core Network PrintSupport Qml Quick QuickWidgets
- Script Sql ${_TEST_QT_COMPONENT}
+ Sql ${_TEST_QT_COMPONENT}
REQUIRED
)
@@ -90,7 +90,7 @@ endfunction()
qt5_query_qmake()
-find_package(Qt5 COMPONENTS Designer Help SerialPort Svg QUIET)
+find_package(Qt5 COMPONENTS Designer Help Script SerialPort Svg QUIET)
function (set_if_target var target)
if (TARGET "${target}")
set(_result ON)