aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEike Ziller <eike.ziller@qt.io>2020-01-03 08:57:33 +0100
committerEike Ziller <eike.ziller@qt.io>2020-01-03 08:57:33 +0100
commit92546d0983278666de1a318d0d192ed09f08be55 (patch)
tree46c3be2f8db47878b1fd14bb78f0aa0e3db147ea /CMakeLists.txt
parent586c6dd92f8c1533eba4a05551145a06d44a0aae (diff)
parent4a00f53c17989b5eedb59967dd09fa17e229fe39 (diff)
Merge remote-tracking branch 'origin/4.11'
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5f42e82315..7587105c1d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -100,6 +100,12 @@ endif()
install(TARGETS OptionalSvg EXPORT QtCreator)
find_package(Clang COMPONENTS libclang QUIET)
+# silence a lot of warnings from building against llvm
+# this would better fit inside a central libclang detection/include cmake file, but since we do not
+# have one put it temporary here
+if(MSVC AND TARGET libclang)
+ target_compile_options(libclang INTERFACE /wd4100 /wd4141 /wd4146 /wd4244 /wd4267 /wd4291)
+endif()
find_package(LLVM QUIET)
if (APPLE)