aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEike Ziller <eike.ziller@qt.io>2020-11-20 11:21:56 +0100
committerEike Ziller <eike.ziller@qt.io>2020-11-23 10:46:39 +0000
commit05a1b2a6e8a048ae2c893e541e7d09ab46ec62e8 (patch)
treec51876dffe7f3178943f0caec79e55921659d2f9 /CMakeLists.txt
parent34a7f6f9f2af0f752d7fada1caeb705bb7ba7432 (diff)
cmake build: Remove unused component "Dependencies"
We don't use it for packaging, nor for github anymore, it duplicates a whole lot of logic, and that only partially (as an example fixing the RPATH for clang tools on macOS is missing), and the Clang part only works with CMake >= 3.14 ("file(READ_SYMLINK"), which was the final trigger of this patch. Change-Id: I21ff6b01297009eff15bda36963e729dea4927c8 Reviewed-by: Cristian Adam <cristian.adam@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 0 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9a34f1c918..4de127c8a6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -107,11 +107,6 @@ endif()
add_subdirectory(doc)
-# CMake will include in a cmake_install.cmake at the end the subdirectories
-# At this point all the previous install scripts have been included
-# Deployment is being done in cmake/CMakeLists.txt
-add_subdirectory(cmake)
-
feature_summary(INCLUDE_QUIET_PACKAGES WHAT
PACKAGES_FOUND PACKAGES_NOT_FOUND
ENABLED_FEATURES DISABLED_FEATURES